overlays wont start anymore

You found a bug or have any issues? Please post them here!
Post Reply
Frans
Posts: 22
Joined: 12 Dec 2015 13:15

overlays wont start anymore

Post by Frans » 07 May 2017 13:29

Hello Bernd,

Since the latest version the overlays won't start anymore. The button "Upcoming Overlays" says there's an overlay waiting but it won't start. It just skipped.
Can you please look into that?

Greetings Frans

User avatar
radio42
Site Admin
Posts: 6126
Joined: 05 Apr 2012 16:26

Re: overlays wont start anymore

Post by radio42 » 07 May 2017 20:22

Just tried them here and they are starting!

Please take a look to your 'Overlay Scheduler Log' - see the 'Tools' ribbon tab and click on the 'Show Log Files' button and take a look to the related Overlay-Log file.
What does your Overlay 'play' - is it maybe a script? And are you maybe having the same issue as in your other post, that this script now doesn't resolve any tracks - because of your history settings?

Note, that you might also activate the 'Debug Logging' - see general settings, section 'More Stuff' - this generates a "Debug_YYYMMDD.log" file (contained in your global log folder), which might reveal the detailed reason.
If needed, just send this to me to analyze it...

Frans
Posts: 22
Joined: 12 Dec 2015 13:15

Re: overlays wont start anymore

Post by Frans » 07 May 2017 23:28

Thank you Bernd,

Yes I'm using a script (with a filter) in the Overlay Scheduler, but the Option "SuppresHistoryCheck" is on.

The Debug option was not set, but there's still a result. I've copied some lines from the Overlay-log and I think you're right. It looks like a script problem.

7-5-2017 10:56:24: WARNING: Overlay 'Nieuws@2017-05-07T10:57:50' not processed (no tracks found with 'Script : Nieuws').
7-5-2017 11:56:32: Overlay:Nieuws, Command:News (Nieuws), Start:7-5-2017 11:57:50 processed
7-5-2017 11:56:32: WARNING: Overlay 'Nieuws@2017-05-07T11:57:50' not processed (no tracks found with 'Script : Nieuws').
7-5-2017 12:56:26: Overlay:Nieuws, Command:News (Nieuws), Start:7-5-2017 12:57:50 processed
7-5-2017 12:56:26: WARNING: Overlay 'Nieuws@2017-05-07T12:57:50' not processed (no tracks found with 'Script : Nieuws').
7-5-2017 13:56:25: Overlay:Nieuws, Command:News (Nieuws), Start:7-5-2017 13:57:50 processed

I've got a non related question: I see now that there is no GlobalPlaylist-Log. How can I activate this?

Greetings

User avatar
radio42
Site Admin
Posts: 6126
Joined: 05 Apr 2012 16:26

Re: overlays wont start anymore

Post by radio42 » 08 May 2017 00:20

There was never a global playlist log, unless you use the related control-command. But I suggest to better use the new global song statistic instead.

However, the error message is exactly what I expected and as such is directly related to your other post. "no tracks found with 'Script : Nieuws" means that your script did not return a single matching track.

It is the same in your other post.
Please activate the Debug Log , so that we can see what the issue might be.
And send me your scripts in questions plus all your related settings, i.e.
- your global history settings
- your restrictions or rules (if defined)

User avatar
radio42
Site Admin
Posts: 6126
Joined: 05 Apr 2012 16:26

Re: overlays wont start anymore

Post by radio42 » 08 May 2017 13:16

See here: viewtopic.php?f=7&t=1871#p9338
(same reason probably!)

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests