rules problem

You have a question or need an advice about how to do something? Ask it here!
User avatar
radio42
Site Admin
Posts: 5564
Joined: 05 Apr 2012 16:26

Re: rules problem

Post by radio42 » 04 Dec 2018 16:16

A new v4.0.5.2 is available which should fix the issue.

mdegroot
Posts: 28
Joined: 17 Mar 2018 09:38

Re: rules problem

Post by mdegroot » 04 Dec 2018 20:19

I have created a test setup on my laptop at home and I tested the new update but the problem isn't solved.
I noticed a test button in the ruleset conditions editor, and when I test a rule that shouldn't be active now,
propprexx says it matches the given date time.

As you can see I made a test rule that's active all day long, every day exept tuesday.
I made a second one that's active only on tuesday.

When I do the test in a script, it still picks jingles that don't mach the rules.

Image
Image

User avatar
radio42
Site Admin
Posts: 5564
Joined: 05 Apr 2012 16:26

Re: rules problem

Post by radio42 » 04 Dec 2018 20:59

Perfect - that is also the right way... I am just preparing a v4.0.5.2 bug-fix release for you, which should fix the issue.

User avatar
radio42
Site Admin
Posts: 5564
Joined: 05 Apr 2012 16:26

Re: rules problem

Post by radio42 » 04 Dec 2018 21:44

Are you sure you updated to the correct version?
I made the same test here and get a different result:
RuleSetTest.jpg
As you can see, here the same test reports, that the test failed.
Also my test script returned the correct tracks. So please test again.

However, please use the latest v4.0.5.3., as there was an issue with an obfuscation tool, which caused a startup error.

mdegroot
Posts: 28
Joined: 17 Mar 2018 09:38

Re: rules problem

Post by mdegroot » 04 Dec 2018 22:05

I had version 4.0.5.2 and now did the update to 4.0.5.3.
When the set hours don't match the current time, pf gives a "not match" notice indeed.
BUT : when the time matches but the day set doesn't match, it still gives a match.

We are halfway ;-)

mdegroot
Posts: 28
Joined: 17 Mar 2018 09:38

Re: rules problem

Post by mdegroot » 04 Dec 2018 22:10

Image

User avatar
radio42
Site Admin
Posts: 5564
Joined: 05 Apr 2012 16:26

Re: rules problem

Post by radio42 » 04 Dec 2018 22:15

Please see my screenshot above. There also the time matches, but the day doesn’t match. The result is failed.
What is wrong with this?

Maybe you did not pressed the tab button to leave the currently edited field - else the field edit isn’t committed yet.

mdegroot
Posts: 28
Joined: 17 Mar 2018 09:38

Re: rules problem

Post by mdegroot » 04 Dec 2018 22:18

I did the test again. Saved the rule. Re-opened it. Pressed test and still a match.

UPDATE : I did the same test now on our on-air pc and the same issue there with the latest version installed.
(only to be sure i could reproduce the problem on a second computer too)

User avatar
radio42
Site Admin
Posts: 5564
Joined: 05 Apr 2012 16:26

Re: rules problem

Post by radio42 » 05 Dec 2018 16:39

I guess I have found the issue - thanks for pointing that out!
I have just uploaded a new v4.0.5.4-beta (so please use the "Check for Beta-Version" menu item to install it).

mdegroot
Posts: 28
Joined: 17 Mar 2018 09:38

Re: rules problem

Post by mdegroot » 05 Dec 2018 17:45

I used the button “check for beta versions” but i get the message “no updates available”

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests