Modstream watcher disabled

You have a question or need an advice about how to do something? Ask it here!
Post Reply
tom_decouttere
Posts: 19
Joined: 10 Jun 2017 07:24
Modstream watcher disabled

Post by tom_decouttere »

I'm not able to start the modstream watcher. Under tools, the button on the ribbon stays disabled no matter what I click.
User avatar
radio42
Site Admin
Posts: 6532
Joined: 05 Apr 2012 16:26
Location: Hamburg, Germany
Contact:
Re: Modstream watcher disabled

Post by radio42 »

What Edition are you using? Note, that the MODStreamWatcher is only enabled in the Premium Edition or higher.
Elase, maybe you didn't setup the Watcher settings correctly. Have you checked them in the geneal settings, section Streaming... ?
tom_decouttere
Posts: 19
Joined: 10 Jun 2017 07:24
Re: Modstream watcher disabled

Post by tom_decouttere »

I had to connect to a _working and playing_ stream with the Mod Stream settings where it worked, and then revert to the intented stream.
tom_decouttere
Posts: 19
Joined: 10 Jun 2017 07:24
Re: Modstream watcher disabled

Post by tom_decouttere »

I have this again, where the modstream button is unavailable again. This happens if I open it, the mod stream player opens in full window, not showing the main window anymore. If I press the close button, then the modstream is unavailable. It used to be like earlier the modstream showed just at the bottom of the page, not fullscreen. I must be something with the fullscreen. I have v4.1.1.0
User avatar
radio42
Site Admin
Posts: 6532
Joined: 05 Apr 2012 16:26
Location: Hamburg, Germany
Contact:
Re: Modstream watcher disabled

Post by radio42 »

When you open the MODStreamPlayer in Full Window mode - you can resize it again and then dock it to the the bottom of the page.
No need to close it! Once you closed it - you need to Stop the MODStreamWatcher first - by clicking the MODStream ribbon button from the Tools ribbon tab. Wait a little until it is closed! This ribbon button is for sure not disabled.

If nothing helps, close ProppFrexx, go to your AppUserData folder (%appdata%/radio42/ProppFrexx ONAIR/4.0) and delete the file called 'ProppFrexx ONAIR.layout', and then restart ProppFrexx - this will reset the entire layout.
tom_decouttere
Posts: 19
Joined: 10 Jun 2017 07:24
Re: Modstream watcher disabled

Post by tom_decouttere »

Yes, it was disabled, nothing helped, you have to go to general settings, change to a stream that is on the air, play it but this is annoying as you have to interrupt the program, then the mod streamer wakes up again and in General Settings you can go for the intented stream again. There is something in this that shouldn't be. Resizing the window worked this time, yes it should be docked.
User avatar
radio42
Site Admin
Posts: 6532
Joined: 05 Apr 2012 16:26
Location: Hamburg, Germany
Contact:
Re: Modstream watcher disabled

Post by radio42 »

I just checked the code. There is only one place which en/disables the MODStream ribbon button - and this is checking the following:
- it checks if you are using at least a Premium Edition
- it checks if you have enabled UAC but disabled the user right for the MODStream
As the later is only available in the Enterprise Editiln and you have a Premium - none of the 2 condition could disable the button.
Please send me a screenshot or video of the disabled button - to verify we are talking about the same...

Post Reply