ProppFrexx faders using external midi controller

You have a question or need an advice about how to do something? Ask it here!
Post Reply
phonic
Posts: 221
Joined: 06 Mar 2019 14:45

ProppFrexx faders using external midi controller

Post by phonic » 10 May 2020 18:30

Hi,

I've setup an external mdi controller to control the ProppFrexx faders, all works fine expect the faders. I've tested using MIXER_OUTPUT_VOLUME_SET, MIXER_OUTPUT_VOLUME_CHANGE, butonly got this one working: MIXER_OUTPUT_VOLUME_SLIDE OUT1|${mididata2asvol} but with an annoying delay(even if general fader is set at "very fast" in settings).

What commend should I be using for external midi faders and can you give me an example please?

Thanks!

User avatar
radio42
Site Admin
Posts: 6054
Joined: 05 Apr 2012 16:26

Re: ProppFrexx faders using external midi controller

Post by radio42 » 10 May 2020 18:46

The ..._SLIDE command of course uses a timer to slide the volume - hence the delay!
However, that command uses exactly the same as MIXER_OUTPUT_VOLUME_SET (which is the correct command to use)!
As such, if MIXER_OUTPUT_VOLUME_SLIDE is working, MIXER_OUTPUT_VOLUME_SET should work as well.
You probably have done some config error initially.
Here is command which should work:

Code: Select all

MIXER_OUTPUT_VOLUME_SET OUT1|${mididata2asvol}
If you got further trouble, try to disable the 'Auto Pair MIDI Messages' option in the general settings - as some MIDI controls have issues with this.

phonic
Posts: 221
Joined: 06 Mar 2019 14:45

Re: ProppFrexx faders using external midi controller

Post by phonic » 10 May 2020 19:15

Thanks for your reply Bernd.
I tested all including MIXER_OUTPUT_VOLUME_SET OUT1|${mididata2asvol} and
MIXER_OUTPUT_VOUME_CHANGE OUT1|${mididata2asvol} OUT1|${mididata2asvol}

For some reason only SLIDE seems to work. I've disabled the pair midi messages option. I'll take another look know I know the correct commend to see if I've missed anything while changing commands.

phonic
Posts: 221
Joined: 06 Mar 2019 14:45

Re: ProppFrexx faders using external midi controller

Post by phonic » 10 May 2020 19:22

radio42 wrote:
10 May 2020 18:46
The ..._SLIDE command of course uses a timer to slide the volume - hence the delay!
However, that command uses exactly the same as MIXER_OUTPUT_VOLUME_SET (which is the correct command to use)!
As such, if MIXER_OUTPUT_VOLUME_SLIDE is working, MIXER_OUTPUT_VOLUME_SET should work as well.
You probably have done some config error initially.
Here is command which should work:

Code: Select all

MIXER_OUTPUT_VOLUME_SET OUT1|${mididata2asvol}
If you got further trouble, try to disable the 'Auto Pair MIDI Messages' option in the general settings - as some MIDI controls have issues with this.
My very silly mistake. Working fine now and real time as should. :D

Thanks again for your quick reply and help!

Post Reply

Who is online

Users browsing this forum: No registered users and 16 guests