Grouping tag missing?

You found a bug or have any issues? Please post them here!
Post Reply
Hogeland
Posts: 5
Joined: 20 Mar 2018 15:48

Grouping tag missing?

Post by Hogeland » 01 Aug 2019 16:18

Hi Bernd,

I use the grouping tag in all of my scripts for filtering extra genre info.
Before adding new files into PF i tag them with mp3tag.

Now i recently discovered a problem that PF does not read the Grouping tags in my mp3 files.
In the PF TAG Editor i don't see the Grouping tag in my mp3 files within the Native TAGs tab.
For all of my FLAC files, i also tagged with mp3tag, it works like a charm. The tag is also shown in the Native TAGs tab.
I see differences in the Native Tag descriptions for FLAC and MP3 files. In MP3 i see the Native Tag discription as abbreviations.
Can there be a translate problem for the Grouping tag?

When i use the grouping tag inside the PF TAG Editor i see (besides some extra unusefull created tags :( ) a new created "Contentgroup" in mp3tag, even when i first delete the "Grouping" tag in mp3tag. However, i do not see the new tag in the Native TAGs tab, even after a rescan of my mp3 files in my folder based media library and restart of Proppfrexx. It seems like PF does not recognize the Grouping tag in mp3 files.

What did i do so far:
- Updated to latest version
- Checked the option "Use ID3v2 Found Language"
- Tested with the option "Use Broken Latin1 (.mp3)
- Tested with various mpeg tag options ID3v1 and v2, IDv2.1/IDv2.3/IDv2.4 . IDv2.3 in UTF-16 as well in ISO format.

Some screenshots i made:
- 1st MP3 Native TAGs info
- 2nd FLAC Native TAGs info
- 3rd same MP3 but mp3tag info


Kind regards,

Henk
Attachments
Native TAG_MP3.PNG
Native TAG_FLAC.PNG
mp3tag_add.PNG
mp3tag_add.PNG (11.67 KiB) Viewed 552 times

User avatar
radio42
Site Admin
Posts: 5566
Joined: 05 Apr 2012 16:26

Re: Grouping tag missing?

Post by radio42 » 01 Aug 2019 17:16

FLAC and MP3 use totally different tagging systems, eg. MP3 uses ID3v2, while FLAC uses OGG.

As you can see in this post, ProppFrexx uses for Grouping the following tag:
ID3v2: TIT1, TT1
OGG: GROUPING
viewtopic.php?f=9&t=7

So it seems, that the issue is with mp3tag not storing the Grouping Tag in the TIT1 frame!
Don’t ask me, where mp3tag stores the grouping info, this is something to ask their developer. But it is for sure not in the TIT1 or TT1 frame.
As such, this is not an issue with ProppFrexx!

As for reference: See the ID3v2 description for TIT1 here: http://id3.org/id3v2.3.0

Hogeland
Posts: 5
Joined: 20 Mar 2018 15:48

Re: Grouping tag missing?

Post by Hogeland » 01 Aug 2019 21:43

Hi Bernd,

Thank you for your quick answer.

Leaves me with the question, why can't i also see the TIT1, TT1 information in the Native TAGs tab area when i use the Grouping tag within the PF TAG Editor?

I have used the save button so it should been saved to the mp3 file. When i perform a new (re)read of the saved tag, i would expect at least to see the new created Grouping tag in the Native TAGs overview. But it isn't.
So it seems PF is not storing / reading the Grouping Tag in the TIT1 frame at a right way either or not all tags are shown as Native TAGs.
When i delete the edited and saved mp3 file from the library and perform a rescan, the Gouping tag (created within PF TAG Editor!) is still missing in either the TAG Editor as in Native TAGs tab...A search with filtering at the genre and grouping tags gives no results so it won't work in my scripts also as i discovered lately.

As far as i can see and could test for now it seems like some (not all) changes like i.e. Grouping made in the PF TAG Editor will be stored in the media file as Contentgroup (according to mp3tag) but not (re)read as own stored tag :D

This also applies for the (by Proppfrexx itself created) BPM tag. I see the BPM tag in mp3tag with the right tag name and value as stated by PF in the Track Data tab. However, I can't see this native tag in de Native TAGs overview. But in contradiction to the Grouping tag i can filter at BPM and there are results shown in the search field. So i guess this tag is not a so called native tag according to PF?
Very confusing...while mp3tag and PF both does a perfect tag job with the OGG (FLAC) files.

Furthermore, i do see both replaygain_track_gain (TXXX1) and replay_gain_peak (TXXX2) , also created by PF in the Native TAGs tab overview.

I don't know how or what but something is wrong or broken. Can't say for now it is in PF or in all of my mp3 files. I'll do some further tests with other applications also.

I'm aware of the incompatibility of the various taggers on the world. However, mp3tag is one of the most famous and common one and i use it for many many years now with several applications and have had no problems at all with it. Nevertheless i shall also ask them to look at this issue. Also very curious what similar 3rd party tagger(s) are suitable for the job and tagging all native tags at the right manner.

Did some further tests this evening en searched for information on tagging:

MP3TAG make use of the GRP1 field for the Grouping tag with ID3v2.3 and TIT1 for the Contentgroup tag according their help page at https://help.mp3tag.de/main_tags.html
So it seems we have two ways to place extra information with our media whereby Grouping (GRP1) is the most common used for extra additional Genre info as far as i know and we have Contentgroup (TIT1), generally used for Grouping for MP4 / Work name for MP3. After some tests i can see that PF writes his "Grouping" tag as a "TIT1 Contentgroup" tag in ID3v2.3. Thus mp3tag reads the right stored tag by PF. And for FLAC, changes in the Grouping tag is neatly saved as "GRP1 Grouping" tag. PF writes the same Grouping content in the editor at multiple fields for different types of media? As far as i can see, this is not logical and really confusing.

Kind regards,

Henk

User avatar
radio42
Site Admin
Posts: 5566
Joined: 05 Apr 2012 16:26

Re: Grouping tag missing?

Post by radio42 » 01 Aug 2019 23:43

ProppFrexx would store the Grouping in the TIT1 frame. The only reason when it would not store it is, if the tag frame is broken.
So maybe your mp3 file’s tag structure Is somehow corrupt?
You can send a test file to check... but I won’t be able to check before next week when I return from vacation.

User avatar
radio42
Site Admin
Posts: 5566
Joined: 05 Apr 2012 16:26

Re: Grouping tag missing?

Post by radio42 » 05 Aug 2019 17:12

Any News?
You wanted to send me an audio file look at?

User avatar
radio42
Site Admin
Posts: 5566
Joined: 05 Apr 2012 16:26

Re: Grouping tag missing?

Post by radio42 » 08 Aug 2019 17:55

Seems you found the issue, as I don’t hear anything anymore?!

Hogeland
Posts: 5
Joined: 20 Mar 2018 15:48

Re: Grouping tag missing?

Post by Hogeland » 19 Sep 2019 11:15

Hi Bernd,

No further news so far.
For now, i've solved it to make a action rule in mp3tag to create a extra Contentgroup tag out of the grouping tag for my mp3's
That will do the job.

Thank you for your support!

Regards,
Henk

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests