How do I mute the post microphone sound and just hear pre?

You have a question or need an advice about how to do something? Ask it here!
Post Reply
Gary Mac
Posts: 23
Joined: 27 Jun 2013 17:05

How do I mute the post microphone sound and just hear pre?

Post by Gary Mac » 01 Aug 2013 02:33

Hard to explain this but i'll give it a go:

It may help first if I explain my setup for web broadcast:

I have a Motu 828 mk2 external soundcard plugged into the PC that I have OnAir installed.

I plug my Monitoring headphones directly into my soundcard.

Here's the issue:

During my broadcast I can hear both the pre and the post sound of my mic voice in my headphones.
Pre being my instant voice, and post being the mic voice with about quarter of a second of latency.

(Hard to talk when hearing this lol)

I tried to make adjustments in my soundcard software mixer controller. I can set it to hear just the
pre instant voice (which comes in on input 3/4 from my voice processor pre amp) by setting the
headphone monitoring to monitor input 3/4 of my soundcard, but then loose the music monitoring.
Setting it to monitor main out again bring bag the music, but introduced the post lagged mic voice.


When I used to have an M-Audio soundcard and was using Sam Broadcaster, I could kill the post mic sound from
headphones so I could only hear my pre mic instant voice.

I remember Sam Broadcaster had the setting on the mic channel call 'Bypass Audio Pipeline' and I think
that is how Sam allowed it to kill the post mic sound; sending it straight to the broadcast signal without
having to hear the latency post mic sound, leaving listening to my pre instant mic sound along with the music.

One other way I tried to get around it was to find away in OnAir to reduce the mic latency on post. Bear in mind that the Motu 828 Mk2 is an expensive hefty Motu Asio card. I tried adjusting the soundcards own buffer setting all the way down to 96 but the lag remained the same.

For the record, the players and the mic settings are all configured to the MOTU Asio drivers. When I have the Motu Asio
drivers in use, I can't find a buffer setting in OnAir to adjust to reduce the lag on the Asio set.

I use this same setup btw in Cubase to record vocals with zero latency?

So in a nutshell, what I am trying to achieve is to have the headphones monitoring my pre mic sound (which is instant as I speak) along with the music, with the post mic sound which has latency, piped somehow to the broadcast web output signal without hearing that in my headphones.

I hope this makes sense because I couldn't sleep last night trying to work out how to set up for the way I need it lol.

If there is a solution which I believe there must be, any chance of a step-by-step guide please.

User avatar
radio42
Site Admin
Posts: 5356
Joined: 05 Apr 2012 16:26

Re: How do I mute the post microphone sound and just hear pr

Post by radio42 » 01 Aug 2013 19:18

I guess I fully understand what you are saying and it might all make 'sense' depending on your mixer setup. Meaning you should normally be able to solve all your issues by a certain mixer setup...

1) Latency:
Let's first take a look to the latency issue, as 500ms more sounds like you are NOT using ASIO, but WDM as a drive model.
Please do the following for EACH AND EVERY mixer channel (input AND output):
- Double-Click on the mixer channel name to open its configuration setting
- check, that you have either selected the NONE driver model (for a virtual sub-bus output) OR the ASIO driver model
- note, that the ASIO buffer settings are configured via the 'Buffer' option ion this dialog!
(The buffer length directly defines the latency of the audio signal. A smaller buffer decreases the latency but increases the chance that the playback might break.
For ASIO: The buffer length is defined in samples. Set this to 0 to use default length (see device panel).

Once you made sure, that every mixer channel uses either the NONE or the ASIO driver model - and really NO mixer channel uses the WDM or WASAPI driver model you should not experience and latency issue.
In addition you might set the following general settings within your general settings, section 'General/Audio':
- ASIO Thread = 2
- Update Threads = 4
- Update-Period = 20 ms
- Lookahead Cache = 128 KB

Note, that you should stop and restart ProppFrexx once you changed all the above values to ensure they really take effect.
This should actually reduce your latency...you might then further experiment with the 'Buffer' value within each of your mixer channel configurations!
A Buffer value of 512 or 256 samples should give you decent results I assume.

However, once the latency issue is resolved and brought to a certain minimum, your initial setup still processes two input signals...one is the soundcards internal mixing (the 'Pre Mic' sound) and one is the 'Post Mic' sound. So you should definitely change your setup in some way:
a) you might disable the soundcards internal mixing (the 'Pre Mic' sound)
b) you might disable the 'Post Mic' sound within ProppFrexx (see 2)


2) Pre and Post Mic Sound:
As far as I understand you, the 'Pre Mic' sound is introduced by an on-board soundcard monitoring mixing. Which means your soundcard by itself allows you to monitor your input signal and route that directly to a certain soundcard output (internal monitoring with of course zero latency). The 'Post Mic' sound comes from the ProppFrexx mixer setup...I assume you have a mixer input channel which picks up the signal from your soundcard input and then send a copy of that signal (ProppFrexx internal routing) to a certain mixer output channel.

How to disable the 'Post Mic' sound within ProppFrexx:
Please take a look to the User Manual at page 34ff. respectively page 60ff. See the Mixerr Setup "3. No external Mixer, internal Microphone (extra Monitoring)" or the attached image - this actually shows the mixer setup I will talk about.
Within ProppFrexx you can freely define your mixer setup. This includes the possibility to define any number of mixer channels and its routing. As such, there no hard-coded audio pipeline or broadcasting pipeline like in Sam.
What you basically do within ProppFrexx is to separate your music signal and your final broadcasting signal by using two distinct mixer output channels.

Lets take a look to the mixer setup (as an example):
You might use four output mixer channels and one input mixer channel.

Four Output Mixer Channels:

1. PLAY:
All internal players (except the PFL Player and the Quick Monitor Player)
are routed to this mixer channel for standard play out.
Use the NONE driver model to create a virtual sub-bus mixer channel.
This channel is further routed to the OUT output mixer channel.
Preselect the PFL output channel in the SND function of this channel.

2. OUT:
Only the PLAY mixer channel is routed to this mixer channel for standard play out.
This channel is further copied to MON mixer channel (pre-fading) and uses eg.
the 1st soundcard device (output 1/2) which is eg. connected to external speakers.

3. MON:
The OUT output and the MIC input are routed to this mixer channel and
as such it carries the final mix down of what is effectively being on aired.
This channel uses eg. the 2nd soundcard device (output 3/4) which is eg.
not connected to any external speakers (alternatively it might also use the 1st
soundcard device, but this channel is then muted via the M button!).

4. PLF:
The PFL Player and the Quick Monitor Player are routed to this mixer channel
for monitoring. This channel uses eg. the 3rd (output 5/6, headphone) soundcard device.

One Input Mixer Channels:
1. MIC:
This input uses the 1st (input 1/2) soundcard device (your MIC!) and
is further routed to the MON output mixer channel!
Monitoring of the microphone via the PFL channel can be done using
the SND function of the input mixer channel (or hardware monitoring).

To ensure latency free full-duplex operations you should use ASIO for ALL channels (see above)!

Streaming/Broadcatsing: the MON mixer channel serves as the streaming source channel.

As the default players (DJ Player A-D, Cardwall etc.) are routed to the virtual PLAY channel, which is further routed to the real OUT channel and the OUT channel is further copied to the MON channel, this gives you 2 independent music outputs. The MIC input is routed to the MON output to keep playback and monitoring separate. Meaning:
- at OUT you only hear music, but not the MIC (so you might use this output within your internal mixer headphone setup)
- at MON you hear music and your MIC and therefore you will use this channel for broadcasting

If you do not want to use your internal soundcard monitoring anymore...you might so the following:
Set the OUT output mixer channel to "AutoSND2 at No PFL", which means you will hear the current OUT signal in the PFL channel when you are not performing any pre-fade-listening. In addition enable the SND2 function on the MIC mixer input channel and send that to PFL as well...as such you will always hear your MIC signal as well on the PFL mixer output.

I hope this all makes 'sense' to you and it is now a bit more clear...and gets you a feeling, that the mixer setup and routing allows you almost any configuration.
Attachments
SetupMode3.png
No external Mixer, internal Microphone (extra Monitoring)
SetupMode3.png (9.77 KiB) Viewed 4235 times

Gary Mac
Posts: 23
Joined: 27 Jun 2013 17:05

Re: How do I mute the post microphone sound and just hear pr

Post by Gary Mac » 01 Aug 2013 23:35

Hi Bernd.
Thank you for such a detailed reply, however:

I been at this for 11 hours and still can't get the desired effect that I need for natural headphone monitoring.

Having read through your notes, I am wondering if there is a chance you have misinterpreted my hardware
setup, and the way I am using it.

My Motu 828 m2 Sound Module is 'External' connected via firewire, not internal.
Also my headphones that I use for Monitoring during my show, is plugged into the
headphone socket 'on' the External Sound Module.


So with that in mind, I still can't find a configuration that will completely eliminate the post vocal mic sound from my
headphones :(

I did go through the mixer setup on number 3 as you suggested. What this did was kill the music when activating talkover
by muting the 'MON' channel button the config made, leaving me with my much needed pre mic voice, but this killed the music.
I unmuted the 'MON' channel during talk over to test, and low and behold, I have both the pre and post mic voice together.
Incidentally, that config from wizard number 3 left no send from the mic channel to the OUT, so I use the send button at the
bottom of the channel strip to send it to OUT from there.

I did manage to follow your instructions to reduce the lag my using the Motu asio drivers as you suggested and that worked out better.

Now that you know my Sound Module is external, maybe you have another suggestion?

Just want to rid my headphones of the post mic voice.

Gary Mac
Posts: 23
Joined: 27 Jun 2013 17:05

Re: How do I mute the post microphone sound and just hear pr

Post by Gary Mac » 02 Aug 2013 13:42

Hi Bernd

You have the patience of a saint:)

Ok I have had a nights sleep and I am working on this again as I write:

So far . . . . .

I have recreated all the settings that you have provided for me.

Something very important has just occurred to me looking at your suggested configuration:

I think this configuration suggests using the Motu's output channels to go to an outboard mixing desk to be
utilized for connection to a broadcast device for air transmission?

As mentioned in the first post, I am broadcasting to a Shoutcast server direct from OnAir via the streaming output facility.
I am web based station.

This occurred to me because the Mic Channel you have directed me to connect to the MON channel does not end up at the
OUT channel to be inserted into the stream for web broadcast.

I assume that for streaming direct from OnAir, everything has to end up in the OUT channel so it hits the stream output?
In this scenario, when the MIC hits the OUT for streaming I hear the post mic in my headphones when I only want the pre mic.

I guess that is why Sam Broadcaster has that (Encoders - Record to pipeline, skip output) option to combat that problem.


As a footnote, whilst you been looking at the Motu manual. I don't use the front Mic inputs, I use a DBX Mic pre amp to connect
mic into Channels 3/4 input. Thought it might be important to mention again when you suggesting configs.

Bernd I feel really dumb :(

User avatar
radio42
Site Admin
Posts: 5356
Joined: 05 Apr 2012 16:26

Re: How do I mute the post microphone sound and just hear pr

Post by radio42 » 02 Aug 2013 20:03

It does not make any difference, if the soundcard you are using is an internal or an external one!
I also think, that I fully understand your setup...

We/you also did not talk about TalkOver so far...however, you can also freely define which mixer channel should be muted at TalkOver.
Open the mixer channel configuration (double-click on each mixer channel name) and check the 'Mute On Talkover' setting for each mixer output channel resp. the 'Unmute On Talkover' setting for each mixer input channel.
E.g. in your specific setup you might not want to mute any of the mixer output channels (only the 'MON') - so just uncheck the 'Mute On Talkover' option(s)!

Glad that you sorted the latency issue.

As far as I understand you wanted to use the internal monitoring feature of your Motu soundcard (the main headphone jack at the front).
I have just read the Motu user manual (I hope you did the same)...and it says, that the headphone jack output matches the main outs on the rear panel.
The main outs on the rear panel however is a mix of analog outputs 1 and 2 (which in the above setup should be your 'OUT' mixer channel) AND any live input that you have chosen to monitor from the MOTU 828 control panel as an input (ie. this should be set to your MIC inputs).
If your MIC is eg. connected to input 1/2, then you ALWAYS here the mix of output 1/2 and input 1/2 !

That's it...

So please try this setup (guess this is want you want...):

PLAY: (output)
...as above (NONE driver model with 'Output To: OUT mixer channel).
- disable 'Mute On Talkover'
- set 'Auto SND2 - Off'

OUT: (output)
- use the Motu analog output 3/4
- disable 'Mute On Talkover'
- select 'Auto SND2 - No PFL' (by right-clicking on the SND2 button)

MON: (output)
- use the Motu analog output 5/6
- 'Mute On Talkover' might be enabled
- set 'Auto SND2 - Off'

PFL: (output)
- use the Motu analog output 1/2 (so this is being on your headphone) !!!
- 'Mute On Talkover' might be enabled
- set 'Auto SND2 - Off'

MIC: (input)
- use the Motu input 1/2
- select the input 1/2 as your monitor input in the Motu control panel
- set 'Output To' to copy the signal to your 'MON' mixer output channel
- 'Unmute On Talkover' might be enabled
- set 'Auto SND2 - Off'

Use the 'MON' mixer channel for broadcasting.

At 'OUT' you only hear music, but not the MIC input and 'OUT' is (due to the 'Auto SND2 - No PFL' setting) automatically routed to 'PFL' when no PFL function is active.
As such you will hear on the Motu headphones the mix of output 1/2 and input 1/2 - which is now the mix of the 'PFL' mixer channel and the internal 'MIC'.
Once you do any PFL function...then you will hear the PFL signal plus your MIC input...
I hope this is want you want...

However...I also hope, that you now understand the features...just think a little bit about the flow of the audio signals...and I bet you understand this now yourself... ;-)

User avatar
radio42
Site Admin
Posts: 5356
Joined: 05 Apr 2012 16:26

Re: How do I mute the post microphone sound and just hear pr

Post by radio42 » 02 Aug 2013 20:08

I think this configuration suggests using the Motu's output channels to go to an outboard mixing desk to be
utilized for connection to a broadcast device for air transmission?
No! Please read again...
As said, you will use the 'MON' mixer output channel as the source mixer channel for your streaming.
So go to your streaming server configuration within ProppFrexx ONAIR and see, that you can select the mixer output channel which should be used as the source for your streaming...again, you will use the 'MON' mixer output channel.
However, yes, I did suggest, that you also use the Motu's analog output 5/6 for the 'MON' mixer channel...you might leave these analog outputs 'unconnected' (not connected to anything further) on the Motu side - that is up to you!
This occurred to me because the MIC Channel you have directed me to connect to the MON channel does not end up at the
OUT channel to be inserted into the stream for web broadcast.
As said above - you will use the MON channel for broadcasting and NOT the OUT mixer channel !!!

The reason is explained in my very first reply...in you setup you want to have two separate output mixer channels:
1. One which contains ONLY the music (and is used for your Motu headphone to not include what you called 'Post Mic')
2. One which contains both - the mixed signal of the MIC and the music (and is broadcasted)
I use a DBX Mic pre amp to connect mic into Channels 3/4 input
That doesn't change things in general, just this:
MIC: (input)
- use the Motu input 3/4
- select the input 3/4 as your monitor input in the Motu control panel
All the rest is the same!
Sam Broadcaster has that (Encoders - Record to pipeline, skip output) option to combat that problem
Again, ProppFrexx doesn't need such an option, as you free configure it all here in ProppFrexx!
a) The mixer channels and all their detailed settings
b) which mixer channel to use for broadcasting! (see above and use the 'MON' mixer channel in this setup!)

Gary Mac
Posts: 23
Joined: 27 Jun 2013 17:05

Re: How do I mute the post microphone sound and just hear pr

Post by Gary Mac » 04 Aug 2013 17:56

Success!

I made a image of all the settings that produced the result I needed.
I have included this to show Bernd that I studied his massively helpful and kind support and to confirm if Bernd approves the settings.
Also the image may help others in the future, but remember, this config is unique to my Motu Sound Module.

Final Question Bernd: In; General Settings - Input/Output, I have been saving configs with unique titles
until I arrived at the one that worked. How do I delete the config titles that I no longer want?

Image

User avatar
radio42
Site Admin
Posts: 5356
Joined: 05 Apr 2012 16:26

Re: How do I mute the post microphone sound and just hear pr

Post by radio42 » 05 Aug 2013 19:57

You can 'delete' those mixer setup/config files manually:
Go to the ProppFrexx ONAIR AppUserData folder and locate all "*.mixer" files.
The file name (without the .mixer extension) is the name of the mixer setup/config...thus you can delete all those .mixer files you do not need anymore.


One note to your above setup:
The mixer channels 'DJ A, B and C' are routed to the 'PLAY' mixer output channel (via the 'Output To') setting.
However, the 'PLAY' mixer channel as well as the 'DJ A, B and C' are all using the 'Apply Master Volume' option.
As such the Master Volume would be applied twice (e.g. for 'DJ A' and then again for 'PLAY') - so you might want to remove this option from the 'DJ A, B and C' mixer channels?!

The rest looks okay!
However, are you sure, that you have disabled the 'Auto SND2' also for the 'OUT' mixer channel?
If yes, you would only hear the 'music' when you effectively PFL things...

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests