v3.0.11.28 - stable

This forum will contain general news and announcements made by radio42.
User avatar
radio42
Site Admin
Posts: 5571
Joined: 05 Apr 2012 16:26

Re: v3.0.11.28 - stable

Post by radio42 » 27 Jan 2013 20:33

@Michael Bouwmeester,
I guess I see what the issue is - it'll be fixed in the next version!


@Michael,
When you look at your effective streaming server, you'll see, that this is NOT a SC2 server, but a SC1 server.
As such you should NOT provide any 'Source ID' - as when you provide a 'Source ID' ProppFrexx will use the SHOUTcast v2 protocol - which can obviously not be used with a v1 server.
So simple remove the 'Source ID' from your config and leave that field empty!

grebda
Posts: 53
Joined: 21 Apr 2012 14:03

Re: v3.0.11.28 - stable

Post by grebda » 30 Jan 2013 21:52

PLEASE HELP!
Not working FUNCTIONS MIDI! I had to set the FEADER Jarring of the FEADER in the internal mixer! And when I put the FEADER"Up" so mute PFL ! Now FEADER give up when it does not mute PFL ! WHY ? HELP PLEASE
SORRY FOR MY VERY BAD ENGLISH !! :-( :-(

User avatar
radio42
Site Admin
Posts: 5571
Joined: 05 Apr 2012 16:26

Re: v3.0.11.28 - stable

Post by radio42 » 30 Jan 2013 22:44

@Michiel,
have you set your MIDI conroller to use the Mackie Control protocol?
If yes, what I assume, the channel level meters should normally fall down to 0 by itself - at least if they run in 'Peak Level' mode - which should be the default.
Check your user-manual of the MIDI controller or check, if there are any settings within the MIDI controller setup to .
I.e. the Mackie Control Protocol defines, that the level meter display should automatically fall down.
However, where exectly do you trigger the "EXEC_SEND_MIDI_MCU level|0|${mixerlevel}" command?
Normally this can/should be done in the 'OnTimer' event using an update interval of around 100ms.
The level meters can not be 'calibrated' - the Mackie Control Protocol defined an exact range of the level meters (i.e. when to lit each of the 12 available signal LEDs).
But yes, the next version will automatically resolve the ${mixerlevel} macro (and the other equivalent macros), so that the resolve exactly what is being shown on the PF level meter - I simply have overseen that in the current version!

@grebda,
I'd like to help - but i am affraid I do not fully understand your exact issue?!
What exactly is not working? What exact events are you using, what exact control-commands are you using and what is your current MIDI-Mapping?
What mixer-channel are you having an issue with (input or output)?
What are your mixer-channel configuration settings (e.g. Mute On Talkover etc.)?

Michiel Bouwmeester
Posts: 69
Joined: 04 Nov 2012 16:07

Re: v3.0.11.28 - stable

Post by Michiel Bouwmeester » 31 Jan 2013 16:49

Hi Bernd,

This midi panel runs in various modes. (unfortunally not very well documented.) Currently the mode is set to "Cubase" but the meter behaviour is in any of the availble modes. (Cubase, nuendo, pro tools, samplitude)

I using the "On timer" event at 100msec, I have set this in the appropriate mixer channel.
(the meters themsel work perfect)

Clearly the panel does not let the meters "auto fall back" to 0. Can you think of any work around on this ?

User avatar
radio42
Site Admin
Posts: 5571
Joined: 05 Apr 2012 16:26

Re: v3.0.11.28 - stable

Post by radio42 » 31 Jan 2013 23:11

Just to check your MIDI controller.
You might set the OnTimer update period to e.g. 500ms and see, if the level meter on your MIDI console falls inbetween the updates - meaning if it just updates every 500ms and inbetween doesn't change?
However, I'll see, if I can implement a workaround for those consoles in the next release.

Michiel Bouwmeester
Posts: 69
Joined: 04 Nov 2012 16:07

Re: v3.0.11.28 - stable

Post by Michiel Bouwmeester » 02 Feb 2013 15:35

Hi Bernd, you are a winner!

The midi meters work 100% as intended now. No more "hanging" when the fader closes. Also the midi meters work when "PFL" on a channel. Finally the bug with no meters when audio was -999 is fixed. Thanks for the super work!

grebda
Posts: 53
Joined: 21 Apr 2012 14:03

Re: v3.0.11.28 - stable

Post by grebda » 08 Feb 2013 09:51

radio42 wrote:@Michiel,
have you set your MIDI conroller to use the Mackie Control protocol?
If yes, what I assume, the channel level meters should normally fall down to 0 by itself - at least if they run in 'Peak Level' mode - which should be the default.
Check your user-manual of the MIDI controller or check, if there are any settings within the MIDI controller setup to .
I.e. the Mackie Control Protocol defines, that the level meter display should automatically fall down.
However, where exectly do you trigger the "EXEC_SEND_MIDI_MCU level|0|${mixerlevel}" command?
Normally this can/should be done in the 'OnTimer' event using an update interval of around 100ms.
The level meters can not be 'calibrated' - the Mackie Control Protocol defined an exact range of the level meters (i.e. when to lit each of the 12 available signal LEDs).
But yes, the next version will automatically resolve the ${mixerlevel} macro (and the other equivalent macros), so that the resolve exactly what is being shown on the PF level meter - I simply have overseen that in the current version!

@grebda,
I'd like to help - but i am affraid I do not fully understand your exact issue?!
What exactly is not working? What exact events are you using, what exact control-commands are you using and what is your current MIDI-Mapping?
What mixer-channel are you having an issue with (input or output)?
What are your mixer-channel configuration settings (e.g. Mute On Talkover etc.)?
When I have a Microphone 1, up 2, PFL NOmuted!Although the mapping got it set correctly!

hey will say maybe more picture!

Image

If the image is broken, use this link:http://www.nahraj-obrazek.cz/?di=913603133545

The first image is version: v3.0.11.28 and second v3.0.11.27
SORRY FOR MY VERY BAD ENGLISH !! :-( :-(

grebda
Posts: 53
Joined: 21 Apr 2012 14:03

Re: v3.0.11.28 - stable

Post by grebda » 08 Feb 2013 11:33

Yes it works! Great support! Thank you very much!
SORRY FOR MY VERY BAD ENGLISH !! :-( :-(

User avatar
radio42
Site Admin
Posts: 5571
Joined: 05 Apr 2012 16:26

Re: v3.0.11.28 - stable

Post by radio42 » 08 Feb 2013 20:29

Maybe you accidentially changed your PFL mixer configuration.
Please make sure, that the "PFL 2" mixer channel has the "Mute On Talkover" option set in its configuration settings (make a double-click on the PFL 2 mixer channel name to check this).

Mute On Talkover:
If checked this mixer channel is affected by the main talk over functionality. During talk over the output is muted, when talk over has finished it will be un-muted again.
Note: This not only applies to TalkOver!
Actually the mixer channel will be muted whenever an input mixer channel (having the 'Unmute On Talkover' option set) is active.

As such also make sure, that you selected "Unmute On Talkover" in your mixer-input-channel configuration for "MIC 1".
Unmute On Talkover:
If checked this input mixer channel is affected by the main talk over functionality.
During talk over the input is unmuted, when talk over has finished it will be muted again.
Note: This setting not only applies to TalkOver!
Actually having this option set will trigger muting of all output mixer channels having the 'Mute On TalkOver' option set whenever this mixer channel is active.

I just tested it here again and it works as expected.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest