PFOA stops playing

You found a bug or have any issues? Please post them here!
Joche
Posts: 43
Joined: 15 Feb 2014 15:11

PFOA stops playing

Post by Joche » 27 Sep 2016 20:39

We have an issue with our mainserver running PFOA4 latest version with schedule and mod stream monitor running on a Windows 10 machine.
Several times now PFOA stops playing, in the middle of a track or when starting over a new script. The playlist for the next 2 or 3 hours are there, the players are loaded but nothing plays out. PFOA seems to be connected, but no connection is established to the server. There are no error messages what so ever, but it is not possible to cloese PFOA. I get the usual questions, if I really want to close and if I want to save the playlist, but after that the program won't shut down.
After a restart it runs again like nothing happens for a few hours, or 1-2 days and when repeats.
Please advice!
Head of tech/Editor in chief, Soundic Radio, Sweden - www.soundicradio.com

User avatar
radio42
Site Admin
Posts: 5574
Joined: 05 Apr 2012 16:26

Re: PFOA stops playing

Post by radio42 » 27 Sep 2016 23:04

Does the players stop playing in the middle of a track for any reason? Even if no new playlist or program is about to start?
Or is just the sound output or your streaming connection broken?
It is also unclear to me what role the Mod Stream Player has in your case?
Are you playing regular tracks via the DJ Players or is the Mod Stream Player playing?

However from what you say the problem seems to happen randomly and with no real pattern. So I would say it sounds like a sound card issue.
Are you using any DSPs/VSTs or virtual sound drivers, like breakaway?
If yes try to deactivate them to see if that helps.

And when does the trouble start (as you are already using PF for a long time it was not happening before, so what has changed recently when the issue started)?

But it doesn't really sound like a ProppFrexx bug.

Joche
Posts: 43
Joined: 15 Feb 2014 15:11

Re: PFOA stops playing

Post by Joche » 30 Sep 2016 08:00

Hello again,
I experience both that PFOA stops playing in the middle of a track and at the start of a new playlist/program from the scheduler.
I have tried to run the mixer setup again, the strange thing is that the OUT mixer does not exist anymore and the MAIN mix shows no moving bars at all, even then playing is working normally. This morning i had a new error. The server were down but the metadata was working updating new songs, when I connected to the server PFOA were playing and the connection was green and PFOA said it was connected, but it wasnt. We have as you said been running the server for several months now without any problems at all. We have upgrade from w8 to w10 but that was in july and everything have worked alright until now.
What do you reckon? Shall I re-install PFOA from the beginning or do you have any other advice?
Head of tech/Editor in chief, Soundic Radio, Sweden - www.soundicradio.com

Joche
Posts: 43
Joined: 15 Feb 2014 15:11

Re: PFOA stops playing

Post by Joche » 30 Sep 2016 08:02

Oh, and no DSP/VST running. Problem started on sep 24. And it is always when the DJ players playing.
Head of tech/Editor in chief, Soundic Radio, Sweden - www.soundicradio.com

User avatar
radio42
Site Admin
Posts: 5574
Joined: 05 Apr 2012 16:26

Re: PFOA stops playing

Post by radio42 » 30 Sep 2016 19:03

That really sounds like system/driver/device or OS issue. As ProppFrexx has not been updated, did maybe an unattended Windows 10 update happen, e.g. the Windows 10 Anniversary Update? Or did you change anything else - as it looks strange, that the problem happened just all of a sudden?! It is also strange, that all of a sudden a mixer channel should be missing, as ProppFrexx would not delete that by itself!
I also assume a system issue, as especially what you now describe with your streaming server.
Are you maybe running Remote Desktop with your server? (as I recently had another user reporting, that with the latest Windows 10 version he is having trouble and the sound driver stops working at all once a Remote Desktop session is started - even if he disabled remote/local audio with it) .
Or did you update/install anything else which might interfere with your sound?

I am 'as lost' as you are at this moment, as I never heard about such issues so far - that's why I assume it must be very system related.
Yes, you can try to re-install it, but I doubt, that this will help, as reinstalling the software will basically just copy the executables into your installation folder and nothing else and if it is a system issue, a re-install will not help at all.

But one more question: When you say the DJ Players do stop...
Do you mean that only the audio output stops, but the players continue to play (e.g. you see the progress line moving and the remaining time progressing)?
Or do the DJ Players kind of pause in the middle of a track... and you need to manually press PLAY again in order to resume them?
Or does the players really stop 'working' at all, meaning, if you press PLAY nothing happens at all anymore, but the 'rest' of the UI is working?
If the latter, that indeed sounds like a sound driver issue! As if the sound driver stops working, the players output stop working at all - meaning ProppFrexx behaves for all the 'rest' normally, but 'just' the output and therefore the playback stops working!
This would also explain, why even closing of ProppFrexx kind of works, up until it finally tries to release the so far used sound driver (which is the very last step when closing ProppFrexx) - when it then got stuck!

So I would first try to reinstall or update your sound drivers!

Joche
Posts: 43
Joined: 15 Feb 2014 15:11

Re: PFOA stops playing

Post by Joche » 01 Oct 2016 10:00

Hello yet again. :)
It seems that the audio issue is gone. But the new issue with streaming still exists.
DJ-players are playing, meters shown in the mixer, PFOA states "connected", the metadata is updated but stream is down.
This has happend three times the last 24 hours.
We are now running version 4.0.1.60.
Head of tech/Editor in chief, Soundic Radio, Sweden - www.soundicradio.com

User avatar
radio42
Site Admin
Posts: 5574
Joined: 05 Apr 2012 16:26

Re: PFOA stops playing

Post by radio42 » 01 Oct 2016 20:12

Then check your streaming servers log file. It seems impossible, that a connection is made but the server is down?!
PF might still update the metadata, even with a describe streaming in case you use the 'Force Update' option.

But the situation is a bit unclear to me. Is the server really down? Since if it is down how can metadata be updated then? And if the server is not down what do you then mean by it is connected, but it is not?

And what was the issue with your sound card/playback? What solved it?

Joche
Posts: 43
Joined: 15 Feb 2014 15:11

Re: PFOA stops playing

Post by Joche » 03 Oct 2016 19:57

This is what is logged by shoutcast when server dies. So it seems to me that PFOA stop sending data to the server.
So the thing is that PFOA think its connected, continue to play music and to push the metadata, but the sound is not sent to the stream.

<10/03/16@14:26:19> [source] no data (30s timeout). disconnecting.
<10/03/16@14:26:19> [source] disconnecting from relay host [waiting 30s]
<10/03/16@14:26:20> [main] connecting to yp.shoutcast.com to remove myself [no source]
<10/03/16@14:26:49> [source] creating relay socket
<10/03/16@14:26:49> [source] resolving relay host
<10/03/16@14:26:49> [source] relay host returned error (ICY 401 Service Unavailable) [waiting 30s]
<10/03/16@14:26:49> [source] disconnecting from relay host [waiting 30s]

The soundcard issue seems to be gone after updating audiodrivers.
Head of tech/Editor in chief, Soundic Radio, Sweden - www.soundicradio.com

User avatar
radio42
Site Admin
Posts: 5574
Joined: 05 Apr 2012 16:26

Re: PFOA stops playing

Post by radio42 » 03 Oct 2016 20:05

Are you maybe somehow changing the mixer setup or sources and this the streaming server's mixer channel becomes invalid?
Or it is a funky network error which is somewhere happening between the ProppFrexx PC and your SHOUTcast server?!
But the log file looks like a Relay-Server setup and not a real SHOUtcast source server?
Or where does the 'relay host' error messages do come from??

Joche
Posts: 43
Joined: 15 Feb 2014 15:11

Re: PFOA stops playing

Post by Joche » 03 Oct 2016 20:35

My bad, thats the wrong file, I'll get back the next time it happens with a correct log.
If it was a network error, shouldnt PFOA indicate that it is not connected any more?
It is an old shoutcast 1.9 running as main.
Head of tech/Editor in chief, Soundic Radio, Sweden - www.soundicradio.com

Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests