Listeners Graph

You are missing a feature or need an enhancement? Post your suggestion here!
User avatar
radio42
Site Admin
Posts: 6050
Joined: 05 Apr 2012 16:26

Re: Listeners Graph

Post by radio42 » 03 Sep 2014 15:30

Why don't you ask your provider Centova Cast?
They did not implement the stats in tier servers....so I guess it's fair to ask them to provide some alternative way to get your stats. Simply because you pay a monthly fee to them and it's their task to provide you with such info...

kapsouli
Posts: 2
Joined: 30 Aug 2014 16:13

Re: Listeners Graph

Post by kapsouli » 06 Sep 2014 10:22

i ask him
but he say to me that everithing ok from him
something maybe with the setings in program maybe he said
i dont know

User avatar
radio42
Site Admin
Posts: 6050
Joined: 05 Apr 2012 16:26

Re: Listeners Graph

Post by radio42 » 06 Sep 2014 20:43

? It's pretty obvious.
They are not using a standard Shoutcast or ICEcast server. They are using their own implementation, which doesn't seem to be 100% compatible. And do not implement the standard listener stats interface.
Not that the listener stats interface is fully working with PF and the original servers.
So what would you expect from PF? Be compatible with a none compatible server?

User avatar
radio42
Site Admin
Posts: 6050
Joined: 05 Apr 2012 16:26

Re: Listeners Graph

Post by radio42 » 06 Sep 2014 23:39

Or lets do it the other way around. Please ask CentovaCast to provide you with the interface to query the listener stats.

User avatar
hdradio
Posts: 622
Joined: 10 Apr 2012 17:36

Re: Listeners Graph

Post by hdradio » 03 Nov 2014 18:05

Bernd I have the same problem with the user having issue getting listener count from Centova Icecast.
I signed today to a Centova host and I could dig into the problem.
I noticed that as soon as PF connects to icecast server, reads and displays the listener count, but after a while stops reading that data.
In Centova there is a log and I saw that PF at first, GET sends user "admin" but later sends "source" instead and of course can not return any value.

I have 2 streams "/stream" and "/live.aac". Look at the log when I reconnected the second (live.aac) [I have changed ip addresses to 1.2.3.4]:

Code: Select all

001.02.03.04 - source [03/Nov/2014:16:38:33 +0000] "GET /admin/listclients?mount=%2Fstream HTTP/1.0" 200 359 "-" "ProppFrexx/3.0" 0
001.02.03.04 - source [03/Nov/2014:16:38:33 +0000] "GET /admin/listclients?mount=%2Flive%2Eaac HTTP/1.0" 200 179 "-" "ProppFrexx/3.0" 0
001.02.03.04 - admin [03/Nov/2014:16:38:39 +0000] "SOURCE /live.aac HTTP/1.0" 401 118 "-" "-" 0
001.02.03.04 - source [03/Nov/2014:16:38:39 +0000] "SOURCE /live.aac HTTP/1.0" 200 14000128 "-" "-" 3374
005.06.007.08 -  [03/Nov/2014:16:38:40 +0000] "GET /centovacast.xsl HTTP/1.0" 200 808 "-" "Centova Cast/3.1.1" 0
001.02.03.04 - source [03/Nov/2014:16:38:45 +0000] "GET /admin/listclients?mount=%2Fstream HTTP/1.0" 200 359 "-" "ProppFrexx/3.0" 0
001.02.03.04 - admin [03/Nov/2014:16:38:45 +0000] "GET /admin/listclients?mount=/live.aac HTTP/1.0" 400 82 "-" "ProppFrexx/3.0" 0
001.02.03.04 - source [03/Nov/2014:16:38:52 +0000] "GET /admin/listclients?mount=%2Fstream HTTP/1.0" 200 359 "-" "ProppFrexx/3.0" 0
001.02.03.04 - admin [03/Nov/2014:16:38:52 +0000] "GET /admin/listclients?mount=/live.aac HTTP/1.0" 400 82 "-" "ProppFrexx/3.0" 0
001.02.03.04 - admin [03/Nov/2014:16:38:59 +0000] "SOURCE /live.aac HTTP/1.0" 401 118 "-" "-" 0
001.02.03.04 - source [03/Nov/2014:16:38:59 +0000] "GET /admin/listclients?mount=%2Fstream HTTP/1.0" 200 362 "-" "ProppFrexx/3.0" 0
001.02.03.04 - admin [03/Nov/2014:16:38:59 +0000] "GET /admin/listclients?mount=/live.aac HTTP/1.0" 400 82 "-" "ProppFrexx/3.0" 0
001.02.03.04 - source [03/Nov/2014:16:39:06 +0000] "GET /admin/listclients?mount=%2Fstream HTTP/1.0" 200 362 "-" "ProppFrexx/3.0" 0
001.02.03.04 - admin [03/Nov/2014:16:39:06 +0000] "GET /admin/listclients?mount=/live.aac HTTP/1.0" 400 82 "-" "ProppFrexx/3.0" 0
001.02.03.04 - admin [03/Nov/2014:16:39:09 +0000] "SOURCE /live.aac HTTP/1.0" 401 118 "-" "-" 0
001.02.03.04 - source [03/Nov/2014:16:39:09 +0000] "GET /admin/metadata?mode=updinfo&mount=%2Fstream&song=%CE%94%CF%81%CE%B1%CE%BC%CE%B1%CE%BC%CE%AF%CE%BD%CE%B7%20%2D%20%CE%9A%CF%8D%CE%BC%CE%B1%CF%84%CE%B1 HTTP/1.0" 200 184 "-" "ProppFrexx/3.0" 0
001.02.03.04 - source [03/Nov/2014:16:39:13 +0000] "GET /admin/listclients?mount=%2Fstream HTTP/1.0" 200 362 "-" "ProppFrexx/3.0" 0
001.02.03.04 - admin [03/Nov/2014:16:39:13 +0000] "GET /admin/listclients?mount=/live.aac HTTP/1.0" 400 82 "-" "ProppFrexx/3.0" 0
001.02.03.04 - admin [03/Nov/2014:16:39:19 +0000] "SOURCE /live.aac HTTP/1.0" 401 118 "-" "-" 0
001.02.03.04 - source [03/Nov/2014:16:39:20 +0000] "GET /admin/listclients?mount=%2Fstream HTTP/1.0" 200 359 "-" "ProppFrexx/3.0" 0
001.02.03.04 - admin [03/Nov/2014:16:39:20 +0000] "GET /admin/listclients?mount=/live.aac HTTP/1.0" 400 82 "-" "ProppFrexx/3.0" 0
001.02.03.04 - source [03/Nov/2014:16:39:29 +0000] "GET /admin/metadata?mode=updinfo&mount=%2Flive%2Eaac&song=%CE%94%CF%81%CE%B1%CE%BC%CE%B1%CE%BC%CE%AF%CE%BD%CE%B7%20%2D%20%CE%9A%CF%8D%CE%BC%CE%B1%CF%84%CE%B1 HTTP/1.0" 200 184 "-" "ProppFrexx/3.0" 0
001.02.03.04 - source [03/Nov/2014:16:39:30 +0000] "GET /admin/metadata?mode=updinfo&mount=%2Flive%2Eaac&song=%CE%94%CF%81%CE%B1%CE%BC%CE%B1%CE%BC%CE%AF%CE%BD%CE%B7%20%2D%20%CE%9A%CF%8D%CE%BC%CE%B1%CF%84%CE%B1 HTTP/1.0" 200 184 "-" "ProppFrexx/3.0" 0
001.02.03.04 - source [03/Nov/2014:16:39:36 +0000] "GET /admin/listclients?mount=%2Fstream HTTP/1.0" 200 359 "-" "ProppFrexx/3.0" 0
001.02.03.04 - source [03/Nov/2014:16:39:36 +0000] "GET /admin/listclients?mount=%2Flive%2Eaac HTTP/1.0" 200 179 "-" "ProppFrexx/3.0" 0
005.06.007.08 -  [03/Nov/2014:16:39:40 +0000] "GET /centovacast.xsl HTTP/1.0" 200 913 "-" "Centova Cast/3.1.1" 0
001.02.03.04 - source [03/Nov/2014:16:39:43 +0000] "GET /admin/listclients?mount=%2Fstream HTTP/1.0" 200 359 "-" "ProppFrexx/3.0" 0
001.02.03.04 - source [03/Nov/2014:16:39:43 +0000] "GET /admin/listclients?mount=%2Flive%2Eaac HTTP/1.0" 200 179 "-" "ProppFrexx/3.0" 0
001.02.03.04 - source [03/Nov/2014:16:39:50 +0000] "GET /admin/listclients?mount=%2Fstream HTTP/1.0" 200 359 "-" "ProppFrexx/3.0" 0
001.02.03.04 - source [03/Nov/2014:16:39:50 +0000] "GET /admin/listclients?mount=%2Flive%2Eaac HTTP/1.0" 200 179 "-" "ProppFrexx/3.0" 0

User avatar
hdradio
Posts: 622
Joined: 10 Apr 2012 17:36

Re: Listeners Graph

Post by hdradio » 04 Nov 2014 10:27

radio42 wrote:Are you sure, that you have provided (within your streaming server configuration in ProppFrexx) also the "Admin" username as well as the Admin password?
This is actually needed to retrieve the listeners count!
YES ! I am absolutely sure.
As you can see at the log, at first it sends "admin" but later it becomes "source":

Code: Select all

001.02.03.04 - admin [03/Nov/2014:16:39:20 +0000] "GET /admin/listclients?mount=/live.aac HTTP/1.0" 400 82 "-" "ProppFrexx/3.0" 0
At this point I can see the listeners count. But later it becomes :

Code: Select all

001.02.03.04 - source [03/Nov/2014:16:39:43 +0000] "GET /admin/listclients?mount=%2Flive%2Eaac HTTP/1.0" 200 179 "-" "ProppFrexx/3.0" 0
and does not return any value.

User avatar
radio42
Site Admin
Posts: 6050
Joined: 05 Apr 2012 16:26

Re: Listeners Graph

Post by radio42 » 04 Nov 2014 19:24

Are you sure, that you have provided (within your streaming server configuration in ProppFrexx) also the "Admin" username as well as the Admin password?
This is actually needed to retrieve the listeners count!

I just made a quick test here with an ICEcast server and received the following log entries (when providing the admin password in the PF configuration):

Code: Select all

[2014-11-04  09:20:17] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:18] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:19] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:20] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:20] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:21] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:22] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:23] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:24] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:25] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:26] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:27] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:28] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
[2014-11-04  09:20:28] INFO admin/admin.c Received admin command listclients on mount "/stream.mp3"
And ProppFrexx displayed the Listener count just fine!

User avatar
radio42
Site Admin
Posts: 6050
Joined: 05 Apr 2012 16:26

Re: Listeners Graph

Post by radio42 » 04 Nov 2014 21:40

That is pretty strange; as here it always uses the admin user (as needed).
I'll take a deeper look what might be causing it...very puzzling!

User avatar
hdradio
Posts: 622
Joined: 10 Apr 2012 17:36

Re: Listeners Graph

Post by hdradio » 05 Nov 2014 09:18

Bernd,
With the file you send me, it correctly sends admin to get listeners count but the problem remains. After a sec it can not retrieve any data.

I noticed the difference between working and not working log entries:

Working :

Code: Select all

1.2.3.4 - admin [05/Nov/2014:07:56:49 +0000] "GET /admin/listclients?mount=/test HTTP/1.0" 400 82 "-" "ProppFrexx/3.0" 0
Not working :

Code: Select all

1.2.3.4 - admin [05/Nov/2014:07:57:01 +0000] "GET /admin/listclients?mount=%2Ftest HTTP/1.0" 200 175 "-" "ProppFrexx/3.0" 0
The difference is in mount "/test" vs "%2Ftest"

User avatar
radio42
Site Admin
Posts: 6050
Joined: 05 Apr 2012 16:26

Re: Listeners Graph

Post by radio42 » 05 Nov 2014 17:24

Thanks for the info - I guess I am going to write a small test app to check which syntax is correct for 'CentovaCast'.
However, a regular ICEcast server works with both ways, since both ways are actually correct (the 2nd is simply URL encoded).
There are 2 different ways, just because if you are connected, I need to let BASS do the job to retrieve the listener count (as it already has a TCP channel open to that server - so its quicker).
When the streaming server is not connected, I do use my own code (which in this case seems to work with CentovaCast).

I am just wondering, if it is not the other ways around, as the " 400 " resp. " 200 "... might indicate the HTTP return value - and " 200 " would be the OK result code, whereas " 400 " means ERROR.
?!
So I just want to be sure be change the code again...

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests