Page 1 of 1

silence detection not taking action if next song or url is also silent.

Posted: 16 Jul 2019 14:19
by phonic
If silence is found in a pre-record(presenter error), I've set silence detection to fade to the next item in the playlist and works well. However, if the next item is also dead like it's a url that's live but has no audio, or another bad audio recording, it will not take action and will continue playing silence. Is silence detection waiting for audio before it resets?

Re: silence detection not taking action if next song or url is also silent.

Posted: 16 Jul 2019 15:18
by radio42
Yes, it does! Once silence is detected, it won’t detect silence again until there was ‚noise‘ detected.
Maybe I can for you add a ‚reset‘ command once you skipped to the next playlist item.
However, this will have to wait once I am back from vacation ;-)

Re: silence detection not taking action if next song or url is also silent.

Posted: 16 Jul 2019 16:50
by phonic
Thanks, that would solve the issue.

Enjoy your vacation.

Re: silence detection not taking action if next song or url is also silent.

Posted: 24 Aug 2019 09:21
by phonic
Hi,
Any idea when this new option will be added?

Re: silence detection not taking action if next song or url is also silent.

Posted: 24 Aug 2019 09:58
by radio42
It is still on the wish list. Hopefully to the next release I guess.

Re: silence detection not taking action if next song or url is also silent.

Posted: 28 Aug 2019 22:02
by radio42
A new v4.1.3.1-update is available.
In this version you can use the MIXER_IN/OUTPUT_SILENCEDETECTION_ON command to also reset the silence detection.
E.g. when silence was already detected, it won't normally detect silence again. Using this command, you can reset it, so that silence would be detected again after the defined time and thus the OnSilence event will be raised again as well.

Re: silence detection not taking action if next song or url is also silent.

Posted: 29 Aug 2019 22:33
by phonic
radio42 wrote:
28 Aug 2019 22:02
A new v4.1.3.1-update is available.
In this version you can use the MIXER_IN/OUTPUT_SILENCEDETECTION_ON command to also reset the silence detection.
E.g. when silence was already detected, it won't normally detect silence again. Using this command, you can reset it, so that silence would be detected again after the defined time and thus the OnSilence event will be raised again as well.
Thanks, I will give it a try.