lost connection GPIO-client

You found a bug or have any issues? Please post them here!
Post Reply
User avatar
Michel67
Posts: 134
Joined: 28 Nov 2016 19:53

lost connection GPIO-client

Post by Michel67 » 03 Feb 2020 10:24

Yesterday evening the connection between PF and D&R Airlite suddenly broken. The program and music continued undisturbed, but operation was no longer possible via the Airlite. In the GPIO Client it was no longer possible to switch it on. After switching the entire system off and on again, without desired result, PF reinstalled, this was the solution. This has already happened last year. Reason unknown.

User avatar
radio42
Site Admin
Posts: 6201
Joined: 05 Apr 2012 16:26

Re: lost connection GPIO-client

Post by radio42 » 03 Feb 2020 13:55

The solution ‚sounds‘ like a PF issue, but in fact it is the other way around.
We already investigated with another customer, that sometimes (most probably due to other Windows updates) the D&R installed drivers become invalid.
When you now reinstall PF, it rescans the available drivers and takes the fresh ones. (There is effectively no need for a PF reinstall, a rescan of the sound card drivers in the general settings might have also saved the issue). ...
It is now important to understand, that D&R does NOT provide any dedicated drivers with their mixers!
Instead a generic OS related driver is used, which comes with the mentioned problems.
So unless you never run any OS update all would be fine!
Essentially you need to go back to D&R and report such issues, I can not offer any solution.
The only good solution would be, that D&R should provide dedicated and stable drivers of their own.
I sorry to be so clear here.

User avatar
Michel67
Posts: 134
Joined: 28 Nov 2016 19:53

Re: lost connection GPIO-client

Post by Michel67 » 03 Feb 2020 17:33

it was definitely not my intention to write this as a PF issue, I apologize for that. Had it posted better in another section. I am now convinced that most problems are caused by windows, but I found it strange now because I had blocked updates until this morning (Win Update Stop by https://www.novirusthanks.org/). Reinstalling PF was done quickly.

User avatar
radio42
Site Admin
Posts: 6201
Joined: 05 Apr 2012 16:26

Re: lost connection GPIO-client

Post by radio42 » 03 Feb 2020 20:25

Ohh, it was not my intention to blame anyone.
And I guess it is also unfair to blame Microsoft.
The core reason is indeed on the D&R side not providing a proper and professional driver.

User avatar
Michel67
Posts: 134
Joined: 28 Nov 2016 19:53

Re: lost connection GPIO-client

Post by Michel67 » 20 Feb 2020 20:22

update: most likely it is the (original) usb cable between pc and Airlite that caused problems recently.Partially melted and exploded this morning, see picture!. Cable was free from other cabling so there are no consequences.
Attachments
unnamed (3).jpg

User avatar
radio42
Site Admin
Posts: 6201
Joined: 05 Apr 2012 16:26

Re: lost connection GPIO-client

Post by radio42 » 20 Feb 2020 20:52

WoooW! That looks odd!

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests