Audio 1sec after start with fader or button

You found a bug or have any issues? Please post them here!
Post Reply
rbsradio
Posts: 13
Joined: 02 Nov 2021 19:44
Audio 1sec after start with fader or button

Post by rbsradio »

Hi, we have an D&R airence mixer and the Pro Version of PF 64bit.
All things worked fine until the last Windows Update and PF update (we did it the same time as maintenance).
Now as we start with faderstart or buttonstart on the mixer, we see the track starting immediately BUT the audio comes after. The wave in the 4 players is running but the audio comes a little bit later (a sec or so). When we click with the mouse in PF on the playbutton of player 1 to 4, we got the same issue.

We are using audio over the usb channels.

Someone an idea?
User avatar
radio42
Site Admin
Posts: 8224
Joined: 05 Apr 2012 16:26
Location: Hamburg, Germany
Contact:
Re: Audio 1sec after start with fader or button

Post by radio42 »

Hi,

As ProppFrexx did not change anything in that regards, I believe, that this issue is due to a latency within the audio driver. Especially, as D&R is not providing any own audio driver, but uses an OS general USB audio driver.
So I can only image, that the changed behavior is related to the OS update.

As such, I doubt, that this is a ProppFrexx bug!
Please also contact D&R for support.

You might experience the same delay with any other default audio player?
You can try to optimize your WASAPI buffer settings in the mixer settings of ProppFrexx and the OS…
Or you might try to use Asio4All ?
User avatar
radio42
Site Admin
Posts: 8224
Joined: 05 Apr 2012 16:26
Location: Hamburg, Germany
Contact:
Re: Audio 1sec after start with fader or button

Post by radio42 »

Have you heard anything new, eg. from D&R?
Maartenvn
Posts: 101
Joined: 21 Aug 2022 19:47
Re: Audio 1sec after start with fader or button

Post by Maartenvn »

We had this same issue in the past. It is because D&R does not offer an ASIO driver for their older devices.

You need to select WASAPI instead of WDM. That greatly improves the latency. You can tweak the settings to get it even better.

You could also install ASIO4ALL but note that this might create a "zombie" ProppFrexx instance when shutting down because the ASIO4ALL driver seems to block the full shutdown of ProppFrexx, which always leaves a background instance/process running. (we had this issue on multiple PCs so we stopped using it and just tweaked the WASAPI settings)

Post Reply