PFL 2 delayed

You have a question or need an advice about how to do something? Ask it here!
Post Reply
grebda
Posts: 53
Joined: 21 Apr 2012 14:03

PFL 2 delayed

Post by grebda » 01 Aug 2013 14:54

Hi
I have a question!
I have the mixer PFL 1, and for this it goes to PFL 2, but PFL 2 is delayed. It's not the ProppFrexxu, but in the Installation menu computer?
SORRY FOR MY VERY BAD ENGLISH !! :-( :-(

User avatar
radio42
Site Admin
Posts: 5630
Joined: 05 Apr 2012 16:26

Re: PFL 2 delayed

Post by radio42 » 01 Aug 2013 15:34

Can you explain a bit more in detail how these 2 mixer output channels (I assume, that these are mixer output channels?) are setup?
And What exactly do you mean by delayed?
Meaning:
- What driver model do they use?
- What is the exact routing?
Are you using the SND function of the 'Copy To' settings of the mixer channel to route PFL1 to PFL2?

THX

grebda
Posts: 53
Joined: 21 Apr 2012 14:03

Re: PFL 2 delayed

Post by grebda » 05 Aug 2013 13:03

Sorry for the delay!

Set the mixer!
DJ A --Copy To--> PLAY
DJ B --Copy To--> PLAY
DJ C --Copy To--> PLAY
PLAY (SND TO PFL1) --Copy To--> OUT
PFL 1 --SND To--> PFL 2, the PFL 2 is delayed
SORRY FOR MY VERY BAD ENGLISH !! :-( :-(

User avatar
radio42
Site Admin
Posts: 5630
Joined: 05 Apr 2012 16:26

Re: PFL 2 delayed

Post by radio42 » 05 Aug 2013 13:54

Please see my questions above...What driver model do you use for each mixer channel and what soundcard device is being used for each mixer channel?
I guess the 'DJ A'..'DJ C' mixer channels are virtual (NONE)?
Is this true for 'PLAY' as well?

Also what is the exact routing settings for your players?
I guess the DJ Players A-C are going to use the 'DJ A'..'DJ C' mixer channels.
Which mixer channel are you using for the PFL Player?

And when is something delayed and how much is something delayed?
Is it when you use the PFL Player?
Is it like a few milliseconds only or more like 500 ms (half-a-second)?

And how do you measure the delay...?

User avatar
radio42
Site Admin
Posts: 5630
Joined: 05 Apr 2012 16:26

Re: PFL 2 delayed

Post by radio42 » 05 Aug 2013 20:40

Any news?

grebda
Posts: 53
Joined: 21 Apr 2012 14:03

Re: PFL 2 delayed

Post by grebda » 06 Aug 2013 16:10

Hello attach settings!
Music is delayed by about 1500 ms in the second PFL
Otherwise the function:
PFL 1 -> Headphones
PFL 2 -> SPEAKERS STUDIO

Distribution of players on DJ A DJ B, DJ C is a simple reason. When I speak only the moderator mutes the music that speaks, and nestišuje all the music on the character!
Attachments
MIXER2.JPG
MIXER2.JPG (71.5 KiB) Viewed 4190 times
MIXER1.JPG
MIXER1.JPG (123.27 KiB) Viewed 4190 times
SORRY FOR MY VERY BAD ENGLISH !! :-( :-(

User avatar
radio42
Site Admin
Posts: 5630
Joined: 05 Apr 2012 16:26

Re: PFL 2 delayed

Post by radio42 » 07 Aug 2013 21:43

What sources are routed to the 'PFL1' mixer channel? - is it only the PFL Player and QuickMonitor Player?
It also seems, that your send the 'PLAY' mixer channel to 'PFL1' ?

However, is there also a delay between 'OUT' and 'PFL1' respectively between 'OUT' and 'PFL2' (should actually be as well I guess)?

What 'Playback Buffer' and 'Update Period' Settings have you set in the General Settings (section General/Audio)?
Try to decrease the 'Playback Buffer' to eg. 300 ms and set the 'Update Period' to eg. 30 ms.

And does the 'delay' start from the beginning or does the delay increase over time?

One issue could be, that your are using the WDM Driver model (which is not a low latency Driver model as it uses a playback buffer) however, typically the latency (delay) should be no more than the given 'Playback Buffer' size (eg. around 200 to 500 milliseconds).

But, if the delay increases over time, then the issue might be a very simple and common one when using WDM and different soundcards:
The soundcards you are using might run at a slightly different sample rate accuracy, eg. your 'SB Play' and your 'Realtek' card (even both are using 44100 Hz) might internally be running at a slightly different speed. One reason, why professional cards do have the ability to be synchronized via a global work-clock!
Eg. your 'SB Play' might internally use a slightly faster or slower samplerate than your 'Realtek' card - this is almost always the case!
As such...over time...the two streams drift apart and as such a delay is noticeable.

The only thing you can do about this is to run your two outputs (in your case PFL 1 and 2) on the same sound card (eg. use the Realtek for both!).
Or use professional sound cards being synchronized via a common world-clock.
Or use a single sound cards supporting multiple parallel outputs.

You can test, if the delay increases over time, if you reset the buffer. To do so select the 'Recreate and Reset' menu item from the mixer channel contecxt menu (right-click on the mixer channel name).
The delay should be much smaller once reset...but might increase over time again....

Alternatively you might try to use a common ASIO driver (eg. ASIO4ALL).

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests