DR Airence Server not started

You have a question or need an advice about how to do something? Ask it here!
User avatar
radio42
Site Admin
Posts: 8422
Joined: 05 Apr 2012 16:26
Location: Hamburg, Germany
Contact:
Re: DR Airence Server not started

Post by radio42 »

I can not solve any hardware stuff. So that info is not helpful and I guess also not the reason.

As said, I assume, that you might also be using an Advantech card? And that this requires the missing DLL?
So maybe you find that DLL (BioDaq.dll) on your old PC?
Bob Van Dongen
Posts: 43
Joined: 10 Nov 2020 17:36
Re: DR Airence Server not started

Post by Bob Van Dongen »

radio42 wrote: 01 Feb 2024 23:55 I can not solve any hardware stuff. So that info is not helpful and I guess also not the reason.

As said, I assume, that you might also be using an Advantech card? And that this requires the missing DLL?
So maybe you find that DLL (BioDaq.dll) on your old PC?
thanks for your quick response again. I copied the file from the installation folder from the old PC to the new PC, unfortunately without any results. I'll continue looking and maybe you have an idea. I was also thinking about ordering a separate USB card to place in the motherboard, who knows, maybe that will help. If it works, I will definitely post here so that it might be useful to you and others if it happens more often.

Sincerely
User avatar
radio42
Site Admin
Posts: 8422
Joined: 05 Apr 2012 16:26
Location: Hamburg, Germany
Contact:
Re: DR Airence Server not started

Post by radio42 »

I also currently have no idea, but I doubt, that it is the USB port, as I assume, that the Audio interface driver of the D&R mixer is working fine and we are only talking about the GPIO functionality?!

However, I am still puzzled, as the exception you showed above is NOT related to any D&R function at all?!, and it is definitely coming from the Advantech interface (which you are not using?)! So I would investigate in that direction.
Bob Van Dongen
Posts: 43
Joined: 10 Nov 2020 17:36
Re: DR Airence Server not started

Post by Bob Van Dongen »

Hi, yes indeed the USB audio channels work well on the Airence and I can also use them in Proppfrexx.

The only thing that doesn't work is turning on/starting the D&R Airence function in the Gpio. Is there any way I can send you a video of what happens in the Gpio?

And what do you mean by Advantech interface?

regards
User avatar
radio42
Site Admin
Posts: 8422
Joined: 05 Apr 2012 16:26
Location: Hamburg, Germany
Contact:
Re: DR Airence Server not started

Post by radio42 »

I guess a video will not help, as I saw it already on your initial screenshot - still, I can not reproduce it nor do I have a solution.

The ProppFrexx GPIO application offers many GPIO interface (not only to the D&R mixers).
One of it is to an Advantech USB card, which offers contact closure relay support. See the main page of the ProppFrexx GPIO client - there you'll find the Advantech interface, which you can enable.
And the exception you posted only comes from that interface. So maybe you enabled that accidentally? Else, it would be impossible to throw such exception.
Regarless, this exception might be thrown in the Error.log file, but it has nothing to do with the D&R interface and not even influence it!

So we are back to square one.
In any case, I can not tell, why it is not working on your machine. As it was working on your older PC, there must be a difference and issue somewhere.
But I don't know which one.
But D&R also comes with their own app for testing the GPIO interface I guess. Is that one working? Else you would have to contact the D&R support.
Maybe they have an issue in their driver - which is "airence.dll".
I just double checked and I am using the official and latest D&R SDK driver from their web site.
Bob Van Dongen
Posts: 43
Joined: 10 Nov 2020 17:36
Re: DR Airence Server not started

Post by Bob Van Dongen »

Hi, good morning, just an update about the GPIO connection not working. After doing everything, only the sound continued to come over the USB of my Airance and no GPIO signal. Tried the following:
USB drivers removed and reinstalled.
Looking for driver updates
USB in bios
USB energy management set to no saving.

Solution
The error probably occurred after I updated the BIOS after installing Windows. Windows completely removed and reinstalled. The system has now been running well for a week.
User avatar
radio42
Site Admin
Posts: 8422
Joined: 05 Apr 2012 16:26
Location: Hamburg, Germany
Contact:
Re: DR Airence Server not started

Post by radio42 »

Glad to hear!
Thx for the update.

Post Reply